How to install Apps that require you to have 5.1 without updating your iOS to 5.1

Apps that require iOS 5.1 tend to be Apple’s way of fighting the Jailbreak community. It’s not like the iPad 2 or iPhone 4S are not compatible with the new updated apps. If only there was a way around this limitation. Glad you asked. There is a way around it and it is pretty simple. The work around works for  iPhoto, iMovie and so far all apps that have asked me to update to 5.1 Please note this method only works on iPhone 4S, iPhone 4 and iPad 2.

The steps to install 5.1 apps on your 5.0.1 device is as follows:

  1. Close AppStore if you have it opened. Don’t forget to check the multitask bar as well for it.
  2. Start up iFile (It’s a jailbreak app in Cydia)
  3. Once in iFile go to /System/Library/CoreServices
  4. Click SystemVersion.plist file
  5. Click Property List Viewer
  6. Click ProductVersion
  7. Change 5.0.1 to 5.1
  8. Click back and and then click Done
  9. Respring your iOS device
  10. Go to App Store and install your desired app.
  11. After it is successfully installed put ProductVersion back to iOS 5.0.1
  12. Click Cydia
  13. Search for iPhoto501Fix and install it
  14. Respring your device
  15. Enjoy 🙂

One thought on “How to install Apps that require you to have 5.1 without updating your iOS to 5.1

  1. Wooow dude!, It’s working awesomely, I had 4.1 Softaware and still works, thx a lot!

Comments are closed.